当前位置:首页 > 问答

通达信macd背离源码

我来帮TA回答

求高手编一个通达信MACD底背离的公式

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
STICKLINE(B1>0,-0.1,0,2,0),COLORRED;
STICKLINE(B2>0,-0.1,0,2,0),COLORFF00FF;
STICKLINE(B3>0,-0.1,0,2,0),COLORYELLOW;
STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;

{希望能够帮到您,也祝您投资顺利}

求通达信K线和MACD背离时,MACD指标就变色或出现记号的码原。。。。

在界面点击右键,再点专家指示,最后点MACD.

求通达信15分钟周期MACD底背离的选股公式

用日线背离的就可以了。

求通达信中把MACD顶底背离信号叠加到分时主图上的公式源码

顶背离,你要确定一下是,dif的背离,还是,dea线的背离,还是macd柱子高低的背离.
提示方式是画线提示还是文字提示还是图标提示
例如下图中的是划线提示的

知道通达信这个指标源码,怎样编出这个指标的选股公式?

你写不下, 你以为别人就能写的下吗?这是一个组合叠加的指标(说白了是个杂种)
里面设置了很多买入条件,不知你要哪个?有w底,买点,满仓等都是买入信号啊!!!
就暂且设置w底选股吧,
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
W底选股:IF(SSS-SSB=2 AND SSS>REF(SSS,1),1,0);
这是一个底部选股比较可靠的指标之一。

求高手帮忙编写一个选股公式;“通达信”软件用。 要求:“必买”选入; 原副图指标公式源码如下:

RSV:= (((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K001:=SMA(RSV,3,1);
D001:=SMA(K001,3,1);
J001:=((2.5 * K001) - (3 * D001));
VAR1001:=ZIG(3,14);
VA2001:=EMA(EMA((WINNER(CLOSE) * CLOSE),3),3);
控筹:=(((VA2001 - REF(VA2001,1)) / REF(VA2001,1)) * 1000);
HUOL:= REF(VAR1001,2) > REF(VAR1001,1) AND VAR1001 > REF(VAR1001,1) AND 控筹 > REF(控筹,1) AND J001 > REF(J001,1);
准备买:= IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK1 ;
必卖: IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK1;
必买: REF(准备买, 1) AND HUOL;
{
你提供的公式是可以直接选股的,是很多的人在用的抄底公式(必买),其中用到未来函数,所以,往往买入后买点又消失了,造成了损失。很多人对包含未来函数的公式不敢用。
为此,我将公式又加了一个限制,前一天出现买入(准备买)信号,当天止跌后买入,经过比较长的一段时间的验证,准确率很高,即使买入后又调整了,幅度也非常有限。
选股时: 买入 等于 1
}