通达信如何设置k线的空心,通达信指标 在某一区间想把上涨的k线画成空心 下降的K线画成实心该怎么做?

Q1:通达信指标 在某一区间想把上涨的k线画成空心 下降的K线画成实心该怎么做?

ZF:=C>REF(C,1) OR C>O;
STICKLINE(ZF,H,L,0,0),COLOR0099FF;
STICKLINE(ZF,C,O,3,1),COLOR0099FF
DL:=C<REF(C,1) OR C<O;
STICKLINE(DL,H,L,0,0),COLORGREEN;
STICKLINE(DL,C,O,3,0),COLORGREEN;

Q2:怎样把通达信的K线阴线设置成空心的

工具栏里面的系统设置里面可以自由设置的

Q3:通达信指标修改,把空心改为实心。这一段码数显示的K线是空心,想把阴线改为实心,阳线保持空心

{只能这样}

{先建一引用指标副图,名为:OCHL}

ND1970:=(YEAR-1970)*365+INTPART((YEAR-1972)/4)-IF(INTPART(YEAR/4)=YEAR/4,1,0)+DAY+(MONTH-1)*30+IF(MONTH<=8,INTPART(MONTH/2),INTPART((MONTH-7)/2)+4)-IF(MONTH>2 AND INTPART(YEAR/4)=YEAR/4,1,IF(MONTH>2 AND NOT(INTPART(YEAR/4)=YEAR/4),2,0));

C1:C;

O1:REF(O,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1)));

H1:HHV(H,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);

L1:LLV(L,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);

===============

{再建一指标,名为:周K线副图}

{周K线副图,源码为:}

WO1:="OCHL.O1#WEEK";

WC:="OCHL.C1#WEEK";

WH:="OCHL.H1#WEEK";

WL:="OCHL.L1#WEEK";

K1:=WO1=REF(WO1,1) AND WC=REF(WC,1) AND WH=REF(WH,1) AND WL=REF(WL,1);

K3:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);

DD:=REF(BARSLAST(K1=0)+1,1),LINETHICK0;

DD1:=CROSS(BACKSET((K1=0 OR K3) AND DD=5,4),0.5),NODRAW;

DD2:=CROSS(BACKSET((K1=0 OR K3) AND (DD=4 OR DD=3),3),0.5),NODRAW;

DD3:=CROSS(BACKSET((K1=0 OR K3) AND DD<=2,2),0.5),LINETHICK0;

BK1:=DD1 OR DD2 OR DD3;

BK2:=CROSS(BACKSET(K1=0,2),0.5);

BK3:=CROSS(BACKSET(K1=0 AND REF(K1=0,1),2),0.5);

WO:IF(BARSLAST(K1=0)=0,O,REF(O,BARSLAST(K1=0))),NODRAW;

K0:=WC>WO OR (WC=WO AND WC>REF(WC,BARSLAST(K1=0)+1));

STICKLINE(K0 AND BK1,WH,WC,0,0),COLORLIMAGENTA;

STICKLINE(K0 AND BK1,WO,WL,0,0),COLORLIMAGENTA;

STICKLINE(K0 AND K1=0,WC,WO,0,0),COLORLIMAGENTA;

STICKLINE(K0 AND (BK2 OR K3),WC,WO,0,0),COLORLIMAGENTA;

STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORLIMAGENTA;

STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORLIMAGENTA;

STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,0),COLORCYAN;

STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,0),COLORCYAN;

STICKLINE(NOT(K0) AND BK1,WH,WO,0,0),COLORCYAN;

STICKLINE(NOT(K0) AND BK1,WC,WL,0,0),COLORCYAN;

STICKLINE(NOT(K0) AND K1=0,WC,WO,8,0),COLORCYAN;

STICKLINE(NOT(K0) AND (BK2 OR K3),WC,WO,8,0),COLORCYAN;

MA1:MA(C,20),COLORWHITE;

MA2:MA(C,60),COLORYELLOW;

MA3:MA(C,120),COLORMAGENTA;

Q4:请教高手帮写3个通达信公式:把涨幅超过9%的K线颜色设置为空心的黄色K线,要求是空心的黄色!!

ZF:=CLOSE>REF(CLOSE,1)*1.09;
STICKLINE(ZF,HIGH,LOW,0,0),COLORYELLOW;
STICKLINE(ZF,OPEN,CLOSE,2.8,1),COLORYELLOW;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);

Q5:通达信K线变色了

估计是你叠加了什么指标。
右击K线看看,有什么可以删除的没得删除了就是。

Q6:求这样的均线和K线变色指标怎么写。。。

MA1:MA(C,N1),COLORGREEN,LINETHICK2;
IF (MA1>=REF(MA1,1),MA1,DRAWNULL),COLORLIMAGENTA,LINETHICK2;